Compatibility with earlier versions
Skip to end of metadata
Go to start of metadata

Backwards compatibility

Geronimo plugin metadata (META-INF/geronimo-plugin.xml) and plugin catalog (geronimo-plugins.xml) content is incompatible with previous versions (1.x and 2.0.x). If you have a geronimo plugin for an earlier version of Geronimo you will have to manually convert it to the new schema. The best way to do this is to build the plugin with maven and use the car-maven-plugin to generate the metadata. See Administering Plugins.

Security configuration of run-as and default identities is incompatible with geronimo 1.x versions. If you use run-as roles or default identities you will have to manually modify your geronimo plans to the new mechanism. See Running Geronimo.

Review backward compatibility issues.

Labels
  • No labels