Status

Current state: Rejected

Discussion thread

JIRA: here


Motivation


According to the ticket there are inconsistencies in naming conventions: "DEFAULT" should be a suffix instead of a prefix.  Therefore certain names should be changed from "DEFAULT_VARIABLE" to "VARIABLE_DEFAULT". However, precautions are necessary because the constants are part of public interfaces.

Public Interfaces

The targeted classes are `org.apache.kafka.clients.CommonClientConfigs` and `org.apache.kafka.streams.StreamsConfig`. 

Proposed Changes

The proposed change would be to deprecate the old variable and add the newly named variable. To make sure everything is backward compatible, we can deprecate the previous constants and added the ones conforming to the naming convention bellow it. The renaming would look like this:

```Java
/**  
 * @deprecated Use {@link #NEW_VARIABLE_DEFAULT} instead.  
 */

@Deprecated  
public static final String DEFAULT_OLDV_VARIABLE = "default.api.timeout.ms";  
public static final String NEW_VARIABLE_DEFAULT = "default.api.timeout.ms";
```

Compatibility, Deprecation, and Migration Plan


Eventually as the old naming variables become less relevant and the community have transitioned to the new variable names, it would be possible to make the former constant variable obsolete by removing them completely. 

Test Plan

The refactoring mainly consists of renaming certain constants. Therefore, there are no breaking changes and tests are not necessary.


Rejected Alternatives

None

  • No labels