Page tree
Skip to end of metadata
Go to start of metadata

Databases

  • MADlib runs on Greenplum database (GPDB) and and PostgreSQL.  The last three major versions of these databases are directly tested with each MADlib release.  Older versions of these databases may work fine as well, but we don't test them explicitly.

MADlib Version

Greenplum

Pivotal HDB/

Apache HAWQ 

PostgreSQL

Upgrade Path from Previous

MADlib Versions*

1.18.0

6.x
5.x

n/a12.x
11.x
1.17.0
1.16
1.15.1
1.17.0

6.x
5.x
4.3.x

Recommend 6.5.0+ for deep learning use cases.

n/a12.x
11.x

1.16
1.15.1
1.15

1.16

6.x
5.x
4.3.x

n/a11.x
10.x
1.15.1
1.15
1.14
1.15.15.x
4.3.x
n/a10.x
9.6
1.15
1.14
1.13
1.155.x
4.3.x
n/a10.x
9.6
1.14
1.13
1.12
1.14

5.x
4.3.x

n/a

10.x
9.6

1.13
1.12
1.11
1.13

5.x
4.3.x

n/a

9.6
9.5

1.12
1.11
1.10
1.125.x
4.3.x
2.x9.6
9.5
1.11
1.10
1.9.1
1.115.x
4.3.x
2.x9.6
9.5
1.10
1.9.1
1.9
1.104.3.x
4.2.x
2.x
1.3.x
9.6
9.5
1.9.1
1.9
1.8
1.9.14.3.x
4.2.x
2.x
1.3.x
9.6
9.5
1.9 and all earlier versions

* If you are on an older version of MADlib you may need to do multiple hops to update to the latest version

Supported Operating Systems

  • macOS: 10.14.6 and higher
  • Ubuntu 18.04
  • CentOS 7
  • CentOS 6
    • In order to use the 1.18.0 MADlib centos 6 rpm installer, it is recommended that at least GLIBCXX_3.4.20 be installed on the system. This can be done by installing gcc >= 4.9.0 (The default gcc on CentOS 6 is 4.4.7 which only provides GLIBCXX_3.4.13)

      • If even after upgrading to gcc >= 4.9.0, rpm install fails with the glibc/glibcxx dependency error, use the 'rpm -i /path/to/rpm --nodeps' command to ignore the dependencies.
    • MADlib requires python version 2.7, so postgres should be compiled/installed with python 2.7.

  • No labels