This Confluence has been LDAP enabled, if you are an ASF Committer, please use your LDAP Credentials to login. Any problems file an INFRA jira ticket please.

Child pages
  • Java version support
Skip to end of metadata
Go to start of metadata

Sling currently supports the following releases of Java

  • 8, as it is a version that many are currently using as a basline
  • 11, as it is the most recent version for which Oracle provides Long-Term Support

Additionally, we aim to test (not necessarily build) Sling with the latest "short-term" Java release. As of 2019-09-18, this is Java 13. This should minimally be reflected in the Sling ITs configuration regarding JDK versions.

References:

  1. Oracle Java SE Support Roadmap
  2. Sling integration tests module descriptor
  • No labels