This Confluence has been LDAP enabled, if you are an ASF Committer, please use your LDAP Credentials to login. Any problems file an INFRA jira ticket please.

Skip to end of metadata
Go to start of metadata

Prior to installing Apache Stratos, verify that you have met the prerequisites described in the following sections on this page:

Apache Stratos software requirements 

Application

Purpose

Version

Download Links

Oracle Java SE Development Kit (JDK)

Required by all the products:

1.6.24 or later / 1.7.*

  • If you are using JDK 1.6, you might need to replace the Java Cryptography Extension (JCE) policy files in your JDK with the Java Cryptography Extension (JCE) Unlimited Strength Jurisdiction Policy files. This will avoid "illegal key size" errors when you try to invoke a secured web service.
  • If you want to build the product from the source distribution, you must use JDK 1.6 instead of JDK 1.7.
  • Oracle and IBM JRE 1.7 are also supported when running (not building) the products.
http://java.sun.com/javase/downloads/index.jsp

If you wish to get support for 32 bits in Apache Stratos, download the Java 32 bits distribution.

MySQL Server

Required to manage database connections.

5.5.0 or later

http://dev.mysql.com/downloads/

MySQL Connector for Java

Required as a standardized database driver for Java platforms and development.

1.7.0 or later

http://dev.mysql.com/downloads/connector/
 GitRequired to check out the source from the Git repository.1.9.0 or later http://git-scm.com/downloads/

Apache Maven

Required to build the product from the source distribution.
RubyRequired as a prerequisite for cartridges.2.1.0 or later https://www.ruby-lang.org/en/downloads/
Zip UtilityRequired to compress & unzip packages used.AnyChoose a zip utility that is compatible with the OS.
Linux Base ImageRequired as a prerequisite for cartridges.2.6.0 or later https://packages.debian.org/squeeze/linux-base
FacterRequired as a prerequisite for cartridges.2.0.0 or later https://downloads.puppetlabs.com/facter/
AMQP Message Broker
Required to communicate with the Cloud Controller and other Apache Stratos profiles.Anyhttps://activemq.apache.org/download.html

Currently ActiveMQ is used by default in the  Apache Stratos installation. However, Apache Stratos also supports other AMQP message brokers such as, WSO2 Message Broker and RabbitMQ .

CEPRequired to analyze & process events of a cartridge.3.0.0 http://wso2.com/products/complex-event-processor

You do not need to download CEP when installing Stratos using the Automated Stratos Configuration approach.

Apache Stratos system requirements

System Requirements
  • Memory - 2GB
  • Disk - 40GB hard disk space
  • Processor - 2.8GHz CPU
Environment Compatibility
  • Operating Systems - Linux (Ubuntu 12.04 64bit server or SUSE Linux Enterprise 11 SP2)

    If you wish to get support for 32 bits in Apache Stratos, download the Java 32 bits distribution.

  • No labels