Blog
Skip to end of metadata
Go to start of metadata

Tapestry 5.5.0 is the new major release. To upgrade, just update the dependency in your build configuration (Maven POM, Gradle build script, etc.) – or Download the new JAR file -- and the new version should just work.

The main new features are:

  • Support for Java 12 bytecode.
  • Support for on-the-fly TypeScript compilation in the tapestry-webresources module. 
  • Ability to use Twitter Bootstrap 3 out-of-the-box (default and same version provided by Tapestry 5.4), Twitter Bootstrap 4 out-of-the-box (introduced in Tapestry 5.5.0) or provide your own CSS (in this case, Tapestry doesn't provide any CSS at all). 
  • The If component now has a then parameter. 

See more details at the release notes.

  • No labels