Child pages
  • Build errors and solutions
Skip to end of metadata
Go to start of metadata

Following is a list of errors observed, and their solutions. If you have something new please mail us at user@tez.apache.org.

  1. Bower ESUDO ~ Cannot be run with sudo

    [ERROR] Failed to execute goal org.codehaus.mojo:exec-maven-plugin:1.3.2:exec (Bower install) on project tez-ui: Command execution failed. Process exited with an error: 1 (Exit value: 1) -> [Help 1]

    Reason: You are running as root or with superuser permissions.
    Solutions:

    1. Recommended: Run without superuser permission, or as a non-root user.

    2. Alternate: If you want to continue as root, add <argument>--allow-root</argument> to arguments tag of exec-maven-plugin in tez-ui/pom.xml.


  2. Failed to execute goal com.github.eirslett:frontend-maven-plugin ~ A required class was missing

    [ERROR] Failed to execute goal com.github.eirslett:frontend-maven-plugin:0.0.22:install-node-and-npm (install node and npm) on project tez-ui: Execution install node and npm of goal com.github.eirslett:frontend-maven-plugin:0.0.22:install-node-and-npm failed: A required class was missing while executing com.github.eirslett:frontend-maven-plugin:0.0.22:install-node-and-npm: org/slf4j/helpers/MarkerIgnoringBase

    Reason: Eirslett frontend-maven-plugin version(0.0.22 in above case) is not compatible with current maven version
    Solution: Force the expected plugging version while building tez-ui: mvn clean package -Dfrontend-maven-plugin.version=0.0.XX
                           For maven version < 3.1 the frontend-maven-plugin version has to be <= 0.0.22
                           For maven version >=3.1 the frontend-maven-plugin version has to be >= 0.0.23


  3. Failed to execute goal com.github.eirslett:frontend-maven-plugin ~ Could not extract the Node archive

    [ERROR] Failed to execute goal com.github.eirslett:frontend-maven-plugin:0.0.22:install-node-and-npm (install node and npm) on project tez-ui: Could not extract the Node archive: Could not extract archive: '/home/.../tez/tez-ui/src/main/webapp/node_tmp/node.tar.gz': EOFException -> [Help 1]

    Reason: Archive extraction exception, may be the tar file is malformed.
    Solution: Clear node_temp and restart setup with correct frontend-maven-plugin version (Check #2).


  4. Failed to execute goal com.github.eirslett:frontend-maven-plugin ~ Could not extract the Node archive

    bower ember-data#1.0.0-beta.11        ECMDERR Failed to execute "git ls-remote --tags --heads git://github.com/components/ember-data.git", exit code of #128.

    Reason: Probably you are behind a firewall which might be blocking git://
    Solution: Try setting git to use https instead of git, by adding the following lines to ~/.gitconfig

  • No labels