Child pages
  • Fedora
Skip to end of metadata
Go to start of metadata

This page documents the requirements and special instructions for building Traffic Server on Fedora platforms. Please let us know if you had to install additional packages on your installations.

The required packages for building can be installed using the following yum command:

sudo yum install make pkgconfig gcc-c++ openssl-devel tcl-devel expat-devel pcre-devel perl-ExtUtils-MakeMaker

It's also recommended that the following packages are installed, but they are not required (and they come pre-install on many systems):

sudo yum install libcap libcap-devel hwloc hwloc-devel ncurses-devel libcurl-devel

If the unwind library is available, install this to get support for the crash log feature:

sudo yum install libunwind libunwind-devel

When building from the Git source, you also need the autoconf / automake toolchain:

sudo yum install autoconf automake libtool

To enable WCCP you will need flex and bison. These should be recent enough to work.

 sudo yum install bison flex

Git

To use Git, you must install the appropriate packages:

 sudo yum install git

For more details how to use Git with our source, please see our Git page.

configure and build

For more details, see the Building page

 ./configure && make

2 Comments

  1. Anonymous

    also needs libtool and sqlite-devel packages installed.

    1. No, SQLite has been culled as a dependency.