Child pages
  • OpenSuSE
Skip to end of metadata
Go to start of metadata

This page documents the requirements and special instructions for building Traffic Server on OpenSuSE.

OpenSuSE 11.x

The following packages must be installed: (tested 11.3 64bit)

 
// expat library
$ wget http://sourceforge.net/projects/expat/files/expat/2.0.1/expat-2.0.1.tar.gz
$ gunzip expat-2.0.1.tar.gz
$ tar xf expat-2.0.1.tar
$ cd expat-2.0.1
$ ./configure
$ make
$ make installlib
 
// pcre library
$ wget ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/pcre-8.13.tar.gz
$ gunzip pcre-8.13.tar.gz
$ tar xf pcre-8.13.tar
$ cd pcre-8.13
$ ./configure
$ make
$ make install

configure & build

Please, check the openssl directory, default directory is "/usr/bin".

// ATS
$ wget http://mirror.apache-kr.org//trafficserver/trafficserver-3.0.1.tar.bz2
$ tar xvf trafficserver-3.0.1.tar.bz2
$ cd trafficserver-3.0.1
$ ./configure 
$ make
$ make install

Building from Apache Subversion source

If building from Apache SVN source (not a distribution file), you must also install the appropriate autoconf packages (this is the same for all OpenSuSE versions):

 

Subversion and git

To use subversion, you must install the subversion package:

 

Git

In order to use Git, you must first install subversion (as above), and then the appropriate git and git-svn package.

 

For more details how to use Git with Subversion, please see our Git page.

  • No labels