Page tree

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Comment: Update from 1.16 to 1.17

Prerequisites 

  1. For using MADlib 1.16 17 Deep Learning module features, users are required to install Keras, Tensorflow and their dependencies separately.

Configurations

  1. Current MADlib 1.16 17 Deep Learning module is tested on the following configurations:
    1. Greenplum v6.2, CentOS 7
    2. Greenplum v6.2, Ubuntu 18
    3. Greenplum v5.1924, CentOS 7
    1. Greenplum v5.1924, Ubuntu 1618
    2. Postgres 10 11 and 1112, CentOS 7
    3. Postgres 10 11 and 1112, Ubuntu 16
    4. Greenplum 6Beta, CentOS 7
    5. 18
    6. Deep Learning library versions 
      1. Keras: 2.2.4 
      2. Tensorflow: 1.13.1
      3. Scipy: 1.2.1
      4. cudNN: 7.1.4 
      5. CUDA: Cuda compilation tools, release 9.0, V9.0.176
    7. GPU configuration: Nvidia Tesla P100-PCIE-16GB
  2. MADlib 1.16 17 Deep learning module is supported for the following Greenplum and python versions:
    1. >= Greenplum 5.0
    2. >= Python 2.7

Known issues with the MADlib 1.16 17 Deep Learning module on Greenplum/Postgres:

...