Page tree

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

  • macOS: 10.14.6 and higher
  • Ubuntu 18.04
  • CentOS 7
  • CentOS 6
    • In order to use the 1.18.0 MADlib centos 6 rpm installer, it is recommended that at least GLIBCXX_3.4.20 be installed on the system. This can be done by installing gcc >= 4.9.0 (The default gcc on CentOS 6 is 4.4.7 which only provides GLIBCXX_3.4.13)

      • If even after upgrading to gcc >= 4.9.0, rpm install fails with the glibc/glibcxx dependency error, use the 'rpm -i /path/to/rpm --nodeps' command to ignore the dependencies.
    • MADlib requires python version 2.7, so postgres should be compiled/installed with python 2.7.

    CentOS
    • 7

    Ubuntu 18
    • .

    04