This Confluence has been LDAP enabled, if you are an ASF Committer, please use your LDAP Credentials to login. Any problems file an INFRA jira ticket please.

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

Starting with Spark 1.0.0, the Spark project will follow the semantic versioning guidelines (Moved permanently to http://semverspark.apache.org/) with a few deviations. These small differences account for Spark's nature as a multi-module project.

Spark Versions

Each Spark release will be versioned:
[MAJOR].[FEATURE].[MAINTENANCE]

...

Alpha Components

When new components are added to Spark, they may initially be marked as "alpha". Alpha components do not have to abide by the above guidelines, however, to the maximum extent possible, they should try to. Once they are marked "stable" they have to follow these guidelines.

API compatibility

An API is any public class or interface exposed in Spark that is not marked as "developer API" or "experimental". Release A is API compatible with release B if code compiled against release A compiles cleanly against B. Currently, does not guarantee that a compiled application that is linked against version A will link cleanly against version B without re-compiling. Link-level compatibility is something we'll try to guarantee in future releases. 

Note, however, that even for features "developer API" and "experimental", we strive to maintain maximum compatibility. Code should not be merged into the project as "experimental" if there is a plan to change the API later, because users expect the maximum compatibility from all available APIs.

versioning-policy.html