Page tree

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Comment: Migrated to Confluence 5.3

Table of Contents
maxLevel2
styledecimal

Before starting

Before starting the upgrade process, with 1.2.0-M1 running, perform the following actions either via REST or admin console:

  1. Create a boolean configuration schema passwordReset.allowed
  2. Create a boolean configuration schema passwordReset.securityQuestion
  3. Create a notification with 
    1. mail template requestPasswordReset
    2. event [CUSTOM]:[]:[]:[requestPasswordReset]:[SUCCESS]
    3. user filter token!=$null 
    4. recipients: flag only Include users matching About
  4. Create a notification with 
    1. mail template confirmPasswordReset
    2. event [CUSTOM]:[]:[]:[confirmPasswordReset]:[SUCCESS]
    3. user filter token!=$null
    4. recipients: flag only Include users matching About

Source changes

POM

In the root pom.xml:

  • change parent/version from 1.2.0-M1 to 1.2.0
  • change properties/syncope.version from 1.2.0-M1 to 1.2.0

Other

Replace the following files with their 1.2.0 counterparts (re-apply any customization previously made).

SYNCOPE-548

SYNCOPE-550

Info
titleUser workflow definition

If not starting with an empty internal storage, please consider importing the first user workflow definition above via admin console.

SYNCOPE-135

Internal storage changes

If not starting with an empty database, the following changes are needed:

SYNCOPE-135

Code Block
languagesql
INSERT INTO Entitlement VALUES("SECURITY_QUESTION_LIST", NULL);
INSERT INTO Entitlement VALUES("SECURITY_QUESTION_READ", NULL);
INSERT INTO Entitlement VALUES("SECURITY_QUESTION_CREATE", NULL);
INSERT INTO Entitlement VALUES("SECURITY_QUESTION_UPDATE", NULL);
INSERT INTO Entitlement VALUES("SECURITY_QUESTION_DELETE", NULL);