Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

  • GCC or a compatible compiler (LLVM/Clang and Intel ICC should work)
    • For ATS v7.0.0, gcc-4.8.1 or later is required, for full C++11 support.
  • PCRE (version 3) with the development include files
  • OpenSSL
  • TCL with the development include files
  • Expat with the development include files
  • Perl and ExtUtils::MakeMaker
  • The hwloc library (not required, but recommended)
  • Posix capabilities (not required, but recommended)
  • unwind library (not required, but needed to provide better crash logs)
  • libcurl and curses/ncurses is required for the traffic_top tool. This includes the devel package of both.
    spdylay library (required to build with SPDY support). Note: This is only supported in version 5.x and 6.x of ATS.

Typically, this means you have to include the appropriate "dev" package. Unfortunately, naming here may vary between different distros and platforms. Development packages are usually named -dev or -devel or some such. For more details, see the instructions for the various distributions and platforms below.

...