Page tree

Versions Compared


  • This line was added.
  • This line was removed.
  • Formatting was changed.


Requirements for installing MADlib:

  • gcc and g++ (For OSX, Clang will work for compiling the source, but not for documentation.)
    • NOTE: On Ubuntu 16.04, you will need to use GCC 4 and not the default compiler (GCC 5) to run MADlib. Refer to MADLIB-1068 for details. The outstanding GCC 5 issue is being tracked under MADLIB-1145.
  • An installed version of HDB/HAWQ, Greenplum Database 4.2+ or PostgreSQL (64-bit) 9.2+ with plpython support enabled.  Note 
    • NOTE: plpython may not be enabled in Postgres by default. 
  • MADlib works with Python 2.6 and 2.7.  Currently, Python 3.x is not supported.
  • cmake (the latest version of cmake might cause issues. Please try cmake 3.5.2 in case you get an error or a segmentation fault.)
    • NOTE: On Centos 6 (possibly other Linux variants), we have seen occasions where cmake will have issues running (seg fault) if the file has been been sourced prior to the cmake execution. If you encounter issues, you can use ldd on the cmake executable to confirm dynamic libraries are picked up from the Greenplum installation directories. If this is the case, start a new shell in which the file is not sourced in your current running shell session. You can reference reference MADLIB-1093 for  for additional details.
  • MADlib works with Python 2.6 and 2.7.  Currently, Python 3.x is not supported.

Installing MADlib

In the $MADLIB_ROOT directory (location of MADlib source) run the following commands: