This Confluence has been LDAP enabled, if you are an ASF Committer, please use your LDAP Credentials to login. Any problems file an INFRA jira ticket please.

Page tree

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

  1. Download the MADlib binary

Upgrade

...

MADlib gppkg.

  • Greenplum Database:
    • Upgrading gppkg to a higher version of MADlib:
      For example, upgrading from 1.15.1 to 1.16

      on Redhat / CentOS run the following as gpadmin:

      Code Block
      languagebash
      gppkg -u <madlib_package_upgrading_to>

      Upgrade the MADlib deployment in the database

      Code Block
      languagebash
      madpack -p <platform> -c <connection> upgrade


    • Upgrading gppkg for the same version of MADlib:
      For example, upgrading from madlib_gppkg_1.16+1 to madlib_gppkg_1.16+2

      on Redhat / CentOS run the following as gpadmin:

      Code Block
      languagebash
      gppkg -u <madlib_package_upgrading_to>

      MADlib deployment in the database does not need to be upgraded as the MADlib version has not changed.

...