...
Code Block |
---|
public abstract class SourceTask implements Task { ... @Deprecated public void commit() throws InterruptedException { // This space intentionally left blank. } public void offsetsFlushedAndAcknowledgedoffsetsFlushedAndAcked(List<SourceRecord> offsetsFlushed) throws InterruptedException { commit(); } ... @Deprecated public void commitRecord(SourceRecord record) throws InterruptedException { // This space intentionally left blank. } public void recordSentAndAcknowledgedrecordSentAndAcked(SourceRecord record) throws InterruptedException { commitRecord(record); } ... } |
...
The name of the callback "commit" is not a very good name for a method telling me that "offsets was committed acknowledged". The name was probably chosen as an indication of what the SourceTask ought to do in the callback. I will argue that there may be lots of different things you want to do in that callback, and that lots of them has nothing to do with commit. What you want to do really depends on the nature of your SourceTask. Therefore I suggest changing the name from "commit" (incorrectly stating what you need to do in the callback) to "offsetsFlushedAndAcknowledgedoffsetsFlushedAndAcked" (stating what you need to react on in the callback). I suggest changing the naming in a backwards-compatible way - deprecating the old method for now.
For consistency, I suggest to also change the naming of the other callback on SourceTask. I suggest changing its name from "commitRecord" to "recordSentAndAcknowledgedrecordSentAndAcked". Also in a backwards-compatible way.
...