How to validate the camel-1.x context xml from Apache Camel web site?
Skip to end of metadata
Go to start of metadata

Since Camel became to be Apache Top Level Project for a while, and all the request to the camel old web site (http://activemq.apache.org/camel/) will be redirect to the new site (http://camel.apache.org). We updated the camel schemas' target namespace to refect the URL change in Camel 2.0. But we don't change the schemas namespace of Camel 1.x to keep the compatibility.

We recently released Camel 2.0-ml, and the site schema maintenance script always copys the latest released Camel version's schema to the default schema without version number. You may meet the schema validation problem if your application spring configuration is still using the old Camel 1.x schema namespace and using the web site schema for validations.

To walk around this issue, you just need to specify the schema version in your Spring configuration's schemaLocation attribute.

Labels
  • No labels