Child pages
  • Supported Environments and Versions
Skip to end of metadata
Go to start of metadata

You are viewing an old version of this page. View the current version.

Compare with Current View Page History

Version 1

Tapestry is compatible with a wide range of app servers, Java versions, and open source libraries. Not all combinations are known to work, however.

Note: blanks in the support matrix tables below do NOT indicate incompatibility. They are just documentation gaps.

If you know of any other known compatibilities or incompatibilities, please add a comment at the bottom of this page, or on the Tapestry Users mailing list mailing list.

Java & Servlet API Versions

Tapestry Version →5.75.65.55.45.3.85.3.0 - 5.3.75.25.15.0.105.0.85.04.1
Java JRE8-148-148-127, 816 - 81,26, 75, 65, 65, 65, 65, 61.4, 5, 6
Servlet API3.0+3.0+3.0+2.5+2.5+2.5+2.4+32.4+32.4+32.4+32.4+32.2-2.3

2 For using Tapestry 5.3.8 with Java 8 see Release Notes 5.3.8

3 Servlet API 2.5 requires JDK 1.5+

App Servers

Tapestry Version →5.5+5.45.3.85.3.0 - 5.3.75.25.15.0.105.0.85.04.1
Apache Tomcat6+

6+





Jetty 9 7-9 6-9 6-86-86-86-86-86-86-7
Glassfish




2.1



Apache TomEE









JBoss EAP
4.2.3





4+
Wildfly/JBoss AS









Heroku









Google App Engine




+



Libraries

These are the library versions known to work (and, in some cases, bundled with Tapestry). Unless otherwise noted, adjacent versions will often work fine as well.

Tapestry Version →5.5+5.4.15.45.3.85.3.75.3.3-5.3.65.3.25.3 - 5.3.15.2.15.25.15.0.165.0.105.0.85.04.1
Hibernate5.1.0.Final
?-4.3.6




3.5.4-3.6.0-3.6.0
3.3.0+



JPA















Spring





3.1.0








jQuery.js
1.12.1













Prototype.js

1.7.1
1.71.71.71.71.6.11.6.11.6.0.31.6.0.31.6.0.21.61.6
Scriptaculous


1.91.91.91.91.91.8.21.8.21.8.2


1.8.0
Bootstrap CSS4.3.1, 3.3.63.3.63.0.2












Moment.js
2.12.0













Less4J

1.2.1-1.9












Underscore.js




1.3.31.1.71.1.7







Java 9+ Dependency Deprecations

With the introduction of the Java module system in version 9, various Java EE dependencies were declared deprecated, and removed entirely in version 11.

This might lead to java.lang.NoClassDefFoundError exceptions for  javax-package classes, like missing javax.xml.bind.JAXBException for tapstry-hibernate.

Until all related libraries and frameworks add the now missing dependencies explicitly, you might have to re-add them yourself, if no other dependency is pulling them into your project.

See https://stackoverflow.com/questions/43574426/how-to-resolve-java-lang-noclassdeffounderror-javax-xml-bind-jaxbexception and https://crunchify.com/java-11-and-javax-xml-bind-jaxbcontext/ for more information about the deprecation and removal of the Java EE dependencies, and how to remedy.



  • No labels