Developing an Application Client to access EJB

":3 Deploy and Run a Java EE Application Client GAppIication clients

This tutorial walks you through configuring, developing and deploying an enterprise application with Eclipse and Geronimo. To run this tutorial, as a
minimum you will be required to have installed the following prerequisite software.

Sun JDK 5.0+ (J2SE 1.5)

Eclipse 3.3.1.1 (Eclipse Classic package of Europa distribution), which is platform specific
Web Tools Platform (WTP) 2.0.1

Data Tools Platform (DTP) 1.5.1

Eclipse Modeling Framework (EMF) 2.3.1

Graphical Editing Framework (GEF) 3.3.1

Details on installing eclipse are provided in the Development environment section. This tutorial is organized in the following sections:

Setting up Eclipse IDE for EJB application development.

Developing EJB Local interface, EJB Remote Interface and Bean Class
Developing a Java Client

Deploy and Run

Let us briefly understand this application. This application will take you through creating a simple Stateless Session EJB. Later we will develop a Java
Application client to access this EJB. EJB development will make use of annotations which are introduced in Java EE5.

Setting up Eclipse IDE for EJB application development.

1. Launch Eclipse and select Window->Open Perspective->Other->JavakEE and select Ok
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%CFS Repository Explaring
[__i;; Database Debug
|3 Database Development

ﬁ* Debug

%},’ Java (default)
E:_,J Java Browsing

EJJaua Type Hierarchy
“Hr JPA Development
== Plug-in Development
|._|>_‘| Resource

EDTeam Synchronizing

| o R"H Cancel

2. Right Click under Project Explorer and create a new EJB project. Mention the fields as shown in the figure. For all the other windows give default
values and select Finish.
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EJB Project
Create an EJB Project and add it to a new or existing Enterprise Application,

Project name: | SimpleEJB

Project contents:
Use default

Cirectary: | C:\Documents and Settings \Administrator \ag 1\SimpleEJB | Browse...

Target Runtme

|Apache Geronimo v2. 1 Runtime [Ngw... ]

Configurations
|Default Configuration for Apache Geronima v2. 1 Runtime

A good starting for working with Apache Geronimo v2. 1 Runtime runtime. Additional facets can later be installed to add
new functionality to the project.

EAR Membership
[] Add project to an EAR.
EAR Broject Mame: | EAR Mew...

Java Package

Create a Java package,

Creates folders corresponding to packages.
Source folder: | SimpleEJE jejbModule | [ Browse...

Mame: | eib| |

(7 Finiit Cancel




4. Right click on SimpleEJB project under project explorer and select properties.
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5. Select Java Build Path and select Add External JARs.



' = Properties for SimpleEJB - o
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6. Browse to the directory <GERONIMO_HOME>\repository\org\apache\geronimo\specs\geronimo-ejb_3.0_spec\1.0.1 and select geronimo-ejb_3.
0_spec-1.0.1 jar.
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e @geronimo—ejb_?r.ﬂ_spec—l.ﬂ. 1.jar
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g File name: |geronimo-ejb_3.ﬂ_spec—1 0.1jar El peEn
My Metwork Files of type: |‘.jar;‘.7.ip EI Cancel |

7. Once done select Ok. You can see the geronimo-ejb_3.0_spec-1.0.1.jar added to the build path. This jar provides the essential classes required
for the EJB development.
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This completes the setting of Eclispe IDE for EJB application development.

Developing EJB Local interface, EJB Remote Interface and Bean Class

1. Right Click on the ejb package and create a new Remote interface CountryCapital as shown in the figure
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2. Enter the fields as shown in the figure and select Finish.
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= New Java Interface - @W

Java Interface

Create a new Java interface.

Source folder: SimpleEJB/fejbMadule

[]Endosing type:

Mame: CountryCapital|

Muodifiers: () public () default private protected

Extended interfaces: Add...

Do you want to add comments as configured in the properties of the current project?
|:| Generate comments

':':7:' ﬁinish l [ Cancel

3. Add the following code as shown below

CountryCapital.java

package ejb;

inport javax.ejb.Renpte;
@Rrenvot e
public interface CountryCapital {
public String capital Name(String countryNane);
}

Here @Remote is an annotation used to declare the interface as a Remote Interface.
4. Similarly create a Local interface CountryCapitalLocal. Add the following code to the interface

CountryCapitalLocal.java

package ejb;

i mport javax.ejb. Local;
@.ocal
public interface CountryCapital Local {
public String capital Name(String countryNane);

Similarly in this code we have @Local annotation which declares this interface as local.

In remote as well as local interface we have the declaration for only one Business method. So only this method will be visible to the application



client. Methods other than capitalName if implemented in the Bean class will be private to Bean class and will not be visible to application client.

5. Next step is to create a Bean Class which will implement the Business method to be executed. Right Click on the jsf package and create a new
class.
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6. Enter the class name as CountryCapitalBean.



= New Java Class

Java Class

Create a new Java class.

Source folder: SimpleEJB/ejbMadule
Package: gjb Browse. ..
[ 1Endosing type:
MName: CDunh’yCapitaIBean|
Modifiers: (=) public () default private ecte
[ labstract [ ]final static
Superclass: java.lang.Object
Interfaces: Add..
Which method stubs would you like to create?
[ ] public static void main{String[] args)
[]constructors from superdlass
Inherited abstract methods
Do you want to add comments as configured in the properties of the current project?
|:| Generate comments
(7 [ Finf<h l [ Cancel
a0

7. Populate the bean class

with the code as follows

CountryCapitalBean.java

package ejb;

i mport javax.ejb.
@t at el ess

St at el ess;

public class CountryCapital Bean inpl ements CountryCapital, CountryCapital Local {
public String capital Name(String countryNane)

{

String capital =new String("No such country");
i f (countryNane. equal sl gnoreCase("Ilndia"))

{
}

capi tal ="New Del hi ";

if (countryName. equal sl gnoreCase("United States OF Anmerica"))

{
}

capi t al ="Washi ngton DC';

i f (countryNane. equal sl gnoreCase(" Chi na"))

{

capi tal ="Bejing";



}

return capital;

This completes the development of EJB application.

(D Warning

Due to some limitations in Geronimo Eclipse Plugin the generated deployment plan(openejb-jar.xml) does not have the correct namespace.
Replace the existing namespace as shown in the figure with the following

<openejb-jar xmiIns="http://www.openejb.org/xml/ns/openejb-jar-2.2" xmins:nam="http://geronimo.apache.org/xml/ns/naming-1.2" xmins:pkgen="
http://www.openejb.org/xml/ns/pkgen-2.0" xmins:sec="http://geronimo.apache.org/xml/ns/security-1.2" xmIns:sys="http://geronimo.apache.org
/xml/ns/deployment-1.2">

\
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Developing a Java Client

1. Select File->New->Project->Java->Java Project. Select Next.
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2. In the New Project Window give the Project name ss ApplicationClient and select Next.



"2 New Java Project

Create a Java project

Create a Java project in the workspace or in an external location.

Project name: | ApplicationClient

Contents

@I Create new project in workspace
O Create project from existing source

Direckary: | C:\Documents and Settings\Administrator\ag 1\ApplicationClient Browse...

JRE

(#) Use default JRE (Currently 'Javas0) Configure default. ..

(") Use a project specific JRE:

C} Use an execution environment JRE:

Project layout

(") Use project folder as root for sources and dass files

{¥) Create separate folders for sources and dass files Configure default. ..

Working sets
[ ] add project to working sets

Wiorking sets: Select...

@ <Back || NextL{\SPH Finish || Cancel




3. On the Java Settings window. Select the Projects tab and click add.
IM
Java Settings

Define the Java build settings.

[ Source | 1= Projects |ﬂ. Libraries " . Order and Elqport|
Reguired projects on the buid path:

Edit...

Remove

@ vext> | Fnsh || cancel

4. Check the box for SimpleEJB and Select OK.



(B Required Project Selaction &3

Select projects to add:
=) SimpleE1B
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5. This will add the SimpleEJB project to the build path of the Application Client as shown in the figure. Select Finish.



a Froj
Java Settings
Define the Java build settings.

(% Source | 1= Projects |l'9|I Libraries " . Order and Eu:port|
Required projects on the build path:

1= SimpleETE | Add... |
Edit...
[ Remove ]

@ < Back Next> | | Fini;bl | cancel
W Il

@ Why to add EJB project to build path :(

This is because the build path is used to find the classes referenced by your Client source code. These classes will be required for
compilation of Client source code.

6. Right click on package appclient and create a new Java Class.



f |
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7. Give the class name as ApplicationClient as shown in the figure. Select Finish.
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8. Populate the ApplicationClient.java with the following code

ApplicationClient.java

package appclient;

i mport java.io.BufferedReader;

i nport java.io.lnputStreanReader;
inport java.util.Properties;

import ejb.CountryCapital;

i nport javax. nanmi ng. Cont ext;

i mport javax.nam ng.|Initial Context;

public class ApplicationCient {
public static void main(String [] args)
{
String capital =new String();
try{
Properti es prop=new Properties();
prop. put (Cont ext . | NI TI AL_CONTEXT_FACTORY, "org.apache. openejb.client.
Renot el ni ti al Cont ext Factory");
prop. put ("j ava. nam ng. provider.url", "ejbd://|ocal host:4201");
Cont ext context = new Initial Context(prop);

CountryCapital nyejb =

(CountryCapital)context.| ookup("CountryCapital BeanRenote");
Systemout.println("Gve the nane of a country");

Buf f er edReader i n= new BufferedReader (new | nput St reanReader (Systemin));
String str="";

str=in.readLi ne();

capi tal =nyej b. capi t al Nane(str);

Systemout.println(capital);



}
cat ch( Exception e)

{
e.printStackTrace();

}

Let us try to understand following code snippet

CodeSnippet

Properties prop=new Properties();

prop. put (Context. | Nl TI AL_CONTEXT_FACTORY, "org.apache.openejb.client.Renotelnitial ContextFactory");
prop. put ("java. nam ng. provider.url", "ejbd://Iocal host:4201");

Context context = new I nitial Context(prop);

CountryCapital nyejb =(CountryCapital)context.|ookup("CountryCapital BeanRenote");

@ Useful Information

The above code suggests that which InitialContextFactory to be used to create the InitialContext. Here we are using org.apache.
openejb.client.RemotelnitialContextFactory to create the InitialContext.

In this case as the EJB server is the naming service provider and has naming service runnning at Port 4201.

So we need to specify the location of the EJB server. In this case it is ejbd://localhost:4201.

Once this is done we have the context that provides us the ability to lookup and get objects.

@ Why is the lookup name CountryCapitalBeanRemote?? :(
This will be discussed in deploy and run section.
9. Next step is to add org.apache.openejb.client. RemotelnitialContextFactory Class to the build path. This is because the application client needs

this Class to create the InitialContext as explained above.
10. Right click on ApplicationClient project under project explorer. Select Properties.
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11. Select Java Build Path. Under Java Build Path select Libraries-> Add External JARs.
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12. Browse to <GERONIMO_HOME>\repository\org\apache\openejb\openejb-client\3.0-beta-2 and Select the jar openejb-client-3.0-beta-2.jar. Select
Ok.

This completes the Application Client Development.

Deploy and Run

This section will take you through the deployment of the EJB application. Later we will run the application client with some sample inputs.

1. To deploy the EJB application on to server Export the EJB application as a jar file. Right Click on SimpleEJB application and Select Export->EJB
JAR File as shown in the figure.



< Java EE - ApplicationClient/src/appclient/ApplicationClient.java - Ec

File Edit Source Refactor Mawvigate Search Project Run  Window Help
5 - - 0-Q- EE G .
i Y
rEPrujectEmlorer £3 = O || 1] applicationClient.java 2 :'
= <}==*{> = = public static
= :,;‘J ApplicationClient * i
= 1_5 arc StIJ_.ng cag
=8 appdient tryd
m ApplicationClient.java Erop=
= JRE System Library [Javasa] prop-1
& openejb-client-3.0-beta-2.jar - C:\AGZ -
&= bin Context conte:
£ B o
R Mew b | CountryCapital
(CountryCapit:
Show In alt+shift+w ¥ System. out.pri
E2) Copy Ctrl4c E'JfFEIEdREEdEJ
String str="";
% str=in.readLir
|5 Paste Crl+v capital=myeib.
¥ Delete Delete System. out.pri
Build Path ¢ ¥
Refactor Alt+5hift+T catoch (Exce
Import r
Export H Eﬁhlﬂilﬂe =
&) Refresh F5 £} Export... .
Close Project
che Geronimo w2, 1 Serw
Validate
Fun As r
Debug As r
Profie As r
[ 1 o Team »

. Browse to the Destination of your choice and Select Finish. This will export the SimpleEJB application as a jar file. This jar will be later deployed
on to Geronimo server

@ Why to Export EJB? Why cannot | use Eclipse for deploying the EJB application on the server?

Due to some limitation Eclipse is not able to deploy the EJB application on to server. This issue will be fixed very soon.

. Start the server and Launch the Administrative Console. Under Applications, Select Deploy New and Deploy the SimpleEJB.jar on the server.
. Once the Deployment is successful. Open <GERONIMO_HOME>/var/log/server.log. Find the following in server.log

Snippet from server.log after deployment of SimpleEJB

18:16:39, 750 INFO [startup] Jndi (name=CountryCapital BeanLocal ) --> Ej b(depl oynent-i d=Si npl eEJB
/ Count r yCapi t al Bean)

18:16: 39, 750 I NFO [startup] Jndi (name=CountryCapital BeanRenote) --> Ej b(depl oynent-i d=Si npl eEJB
/ Count r yCapi t al Bean)



As can be seen openEJB container after deployment suggests the Remote as well as Local lookup names.
In this case since the SimpleEJB application and Java Application Client are running on different instances of JVM. We need to have the

CountryCapitalBeanRemote as the lookup name.
5. Under Eclipse Right Click on the Application Client project and Run as a Java application.

Sample Inputl: India

<] ' W |
{E_g Problems (@ Tasks (ﬁ Properties (4-?4- SErvers (m Data Source Explorer ﬁj
<terminated = ApplicationClient [Java Application] C:\Program Files\IBMJavas0ihintjar

Give the name of a country
India

HNew Delhi

Sample Input2: China

B
<) | T ] B
T Fres
E_r, Problems (@ Tasks (ﬁ Properties (ﬁa SErvers (m Data Source Explorer ([[“‘_—:1 Snippets (E
<terminated > ApplicationClient [Java Application] C:\Program Files\IBMJavas0bin'javaw.exe (Fe

Give the name of a country
Lnina
Eeijing

1

Sample Input3: United States Of America

b Fr =,
E_(, Problems (@ Tasks (ﬁ Properties (4-?4- Servers (m Data Source Explorer (["“[;:1 Snippets (E Can
<terminated = ApplicationClient [Java Application] C:\Program Files\IBM\Java50hinjavaw.exe (Fe b3

Give the name of a country

United States O0f America

Washington DC

1

Sample Input4: France
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E; Problems (@ Tasks (E Properties (ﬁa SErvVers I,m Data Source Explorer ﬂE] Snippets [
<terminated > ApplicationClient [Java Application] C:\Program Files\IBMJava50bin'javaw.exe (Fe

Give the name of a country
France

Information about India, USA and China only available
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