This Confluence has been LDAP enabled, if you are an ASF Committer, please use your LDAP Credentials to login. Any problems file an INFRA jira ticket please.

Child pages
  • KIP-483: Add Broker Version API in Admin Client
Skip to end of metadata
Go to start of metadata

This page is meant as a template for writing a KIP. To create a KIP choose Tools->Copy on this page and modify with your content and replace the heading with the next KIP number and a description of your issue. Replace anything in italics with your own description.

Status

Current stateUnder Discussion

Discussion thread: TBD

JIRA: TBD

Please keep the discussion on the mailing list rather than commenting on the wiki (wiki discussions get unwieldy fast).

Motivation

For either human or application use case, it would be good to know the version of brokers we are talking to, so that we could make some decisions automatically, such as which version of client we should use, such as the use case we face in KIP-447. Note that we already have a legacy support in the Scala BrokerApiVersionsCommand. This would be serving as a good purpose to amend this API gap.

Public Interfaces

A new command line API to help us find the API version:

AdminClient.java
public static List<ApiVersion> getApiVersion(Node target, GetApiVersionOptions options);

And a separate option class:

AdminClient.java
public class GetApiVersionOptions extends AbstractOptions<GetApiVersionOptions>;

Compatibility, Deprecation, and Migration Plan

Since this is a new API, there should be no compatibility concern.

Rejected Alternatives

N/A

  • No labels