Status
Current state: Accepted
Discussion thread: Discussion was skipped. [VOTE] KIP-626: Rename StreamsConfig config variable name
JIRA: - KAFKA-10168Getting issue details... STATUS
Released: 2.7
Please keep the discussion on the mailing list rather than commenting on the wiki (wiki discussions get unwieldy fast).
Motivation
All Kafka Streams configuration parameter are exposed via public variables in StreamsConfig
class and all end with _CONFIG
suffix. However, we added the variable of "topology.optimization"
as TOPOLOGY_OPTIMIZATION
instead of TOPOLOGY_OPTIMIZATION_CONFIG
and thus don't follow the commonly applied naming pattern.
Public Interfaces
We propose to update the variable name to match the common naming pattern. Note, that the parameter name itself is not affected.
public class StreamsConfig { @Deprecation public static final String TOPOLOGY_OPTIMIZATION = "topology.optimization"; // new public static final String TOPOLOGY_OPTIMIZATION_CONFIG = "topology.optimization"; }
Proposed Changes
We rename the public variable to align it to the common naming schema by deprecating the existing variable, and adding a new one with the corrected name.
Compatibility, Deprecation, and Migration Plan
- Users using parameter name
"topology.optimization"
directly (ie, config scripts etc) are not affected - Users using
StreamsConfig#TOPOLOGY_OPTIMIZATION
can update their code toStreamsConfig#TOPOLOGY_OPTIMIZATION_CONFIG
Test Plan
No additional testing is required.
Rejected Alternatives
None.