Skip to end of metadata
Go to start of metadata

Release Notes voor Apache OpenOffice 4.1.3

Vertalingen:   Engels (en) | Duits (de) | Frans (fr) | Italiaans (it)



Algemene opmerkingen

Apache OpenOffice 4.1.3 is een uitgave voor onderhoud, waarbij belangrijke reparaties van problemen, reparaties voor bedreigingen van de veiligheid, bijgewerkte woordenboeken en algemene reparaties worden ingebracht. Alle gebruikers van Apache OpenOffice 4.1.2 of eerder wordt geadviseerd om te upgraden. U kunt Apache OpenOffice 4.1.3 op de bekende plaats downloaden.

Bekijk deze Release Notes om te zien wat er nieuw is in deze versie, als ook de belangrijke opmerkingen met betrekking tot bekende problemen en hun eventuele methoden om die te omzeilen.

Onze database van het systeem voor het volgen van problemen Bugzilla verschaft een gedetailleerde lijst met opgeloste problemen.

Verbeteringen

  • BZ 125980 Set default currency to Euro in Lithuanian locale
  • Een regressie die invloed had op alle tabellen en query's voor databases op Mac OS X werd gerepareerd.
  • Verbeteringen aan de gereedschappen voor het bouwen

Oplossingen van problemen

  • BZ 126622 Base 4.1.2 does not open Tables and Queries in Mac OSX. Deze regressie vanuit 4.1.2, gerepareerd in 4.1.3, had invloed op alle tabellen en query's van databases op Mac OS X.
  • De reparatie voor het probleem voor de veiligheid CVE-2016-1513, eerder alleen ingebracht in de broncode en als een Hotfix patch, is ingebracht in de 4.1.3 binaire uitgave. Bekijk BZ 127045 Enforce Polygon API contracts at run-time.
  • BZ 127100 Make NSIS 3.* a build requirement for building Windows installers
  •  Reparaties van beveiligingsproblemen

Bekijk voor alle problemen de lijst in Bugzilla.

Taalondersteuning

  • OpenOffice 4.1.3 ondersteunt dezelfde talen als de eerdere uitgaven.
  • Er werden geen vertalingen bijgewerkt.
  • De volgende woordenboeken werden bijgewerkt:
Engels (en_GB)Engels (en_US)

 

Duits (de)Duits - Oostenrijk (de_AT)Duits - Zwitserland (de_CH)
Nederlands (nl)Frans (fr)Italiaans (it)
Spaans (es)Roemeens (ro)Russisch (ru)
Khmer (km)Schots Gaelic (gd)Baskisch (eu)
Sloveens (sl)Noors (no)Zweeds (sv)
Portugees Europees (pt_PT)Catalaans (ca_XV)

 

Voor een volledige lijst van beschikbare talen en taalpakketten, bekijk: http://www.openoffice.org/download/ (klik op de taal in het keuzemenu)

Aanvullende ondersteuning platform

Binaire uitgaven worden nog steeds verschaft voor dezelfde platformen als voor de eerdere uitgaven van OpenOffice 4.x:

  • Windows
  • Mac OS X
  • Linux 32-bit (RPM en DEB)
  • Linux 64-bit (RPM en DEB)

Bekende problemen

  • Voor gebruikers van Mac OS:
    • Mac OS X: Apache OpenOffice 4.1.3 zal worden gevlagd door de mogelijkheid Gatekeeper in Mac OS X. Dit is een nieuwe mogelijkheid om te helpen bij de beveiliging tegen malware op systemen van Mac.
      • Voor Mac OS X tot en met 10.11 "El Capitan": Er wordt een procedure uitgelegd op de volgende koppeling om toepassingen, die niet zijn geïnstalleerd via de Mac App store, toch toe te staan te worden uitgevoerd. Bekijk het artikel van Mac support.
      • Voor Mac OS X 10.12 "Sierra": In Finder, Control-klik of klik met rechts op het pictogram van de app. Selecteer Open boven in het contextmenu dat verschijnt. Klik op Open in het vak van het dialoogvenster. Indien daarnaar gevraagd, voor de naam en het wachtwoord van de beheerder in. Dit is alleen nodig als u Apache OpenOffice voor de eerste keer opstart.
    • Mac OS X: Vanwege een bekend probleem in installaties van Oracle Java van Apache OpenOffice op OSX die niet de verouderde Apple Java 6 hebben geïnstalleerd waardoor die niet in staat zijn Oracle Java 7, 8, en mogelijk 9 te herkennen. De tijdelijke oplossing totdat het probleem van Java bug is gerepareerd is om de verouderde versie van Apple Java te installeren vanaf de volgende koppeling: Legacy Apple Java 6. Dit stelt die gedeelten van AOO, die Java nodig hebben, in staat correct te worden uitgevoerd.
  • Voor gebruikers van Windows:
    • Apache OpenOffice 4.1.3 ondersteunt Java 8, wat de aanbevolen configuratie is; maar, speciaal op 64-bit Windows, zou u waarschuwingen kunnen krijgen over het feit dat de versie van Java defect zou zijn. In dat geval, download en installeer het Microsoft Visual C++ 2010 Redistributable Package.
  • Voor ontwikkelaars:
    • Voor ontwikkelaars: het bronpakket van OpenOffice 4.1.3 zal niet worden gebouwd op 32-bit versies van Ubuntu 14.04 en soortgelijke distributies. De bron mislukt in het bouwen van main/svl met deze fout: undefined reference to `__stack_chk_fail'. Dit kan worden opgelost door het kopiëren en plakken van de opdracht die mislukt en die handmatig uit te voeren met daar toegevoegd "-lc" (als het ontbrekende symbool __stack_chk_fail aanwezig is in libc, maar de koppelaar daar niet zoekt).
    • Voor ontwikkelaars: de OpenOffice SDK wil niet gebouwd worden met Java 8. Ofwel bouw met --disable-odk of bekijk de archieven van de dev-lijst voor mogelijke oplossingen.

Informatie over installatie

Instructies voor de installatie zijn te vinden op: http://www.openoffice.org/download/common/instructions.html

Blijf geïnformeerd over Apache OpenOffice

Het wordt aanbevolen om u te abonneren op de Apache OpenOffice announcement mailinglijst om belangrijke informatie over updates van het product en oplossingen voor beveiligingsproblemen te ontvangen. 

Stuur een e-mail naar:  announce-subscribe@openoffice.apache.org.

U kunt het project ook volgen op Twitter, Facebook en Google+.

 

  • No labels